Results 1 to 1 of 1
  1. #1
    Join Date
    May 2004
    Posts
    1

    Unhappy Unanswered: General SQL Error 13059 when connect to MSSQL server via BDE

    Hi,

    I have problem connecting to Microsoft SQL Server 7.0 with BDE (version 5.01) on Windows NT. It returns "Database Engine Error - General SQL Error, BDE Error: 13059, [$33] [$ 3], Alias: toys" Here is the suituation and information about my problem:

    1). It works fine without errors on any Windows 95/98/Me machine with BDE and SQL clients networking tools installed.
    2). The same version of SQL clients networking tools (it comes with MSSQL7 and is also Windows NT compatible) are installed on all computer.
    3). I am logged in as a member of Administrators. Thus, I don't think there would be any security problem.
    4). I have no connection problem when I try to connect to the MS SQL server via ODBC, except I can't make changes to the database due to an "Unique Key not found" Error.
    5). I have already installed DAO and the latest version MDAC after it failed. But it doesn't solve the problem.
    6). I have tried to connect to the MS SQL Server (via BDE) without a database name, but it returns the same error.
    7). Using ODBC on Windows 9X computer yields the same result - we can connect to the database, but we can't make changes.

    Any help would be appreciated. Thank you.


    Yours Truly,
    SnEptUne
    Last edited by SnEptUne; 06-02-04 at 23:13. Reason: Adding details and test cases

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •