If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

 
Go Back  dBforums > Database Server Software > Sybase > 'SYB_BACKUP' not found in interfaces file.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old
Registered User
 
Join Date: Mar 2004
Location: Hyderabad, India
Posts: 8
'SYB_BACKUP' not found in interfaces file.

Hi

I am working in Sybase on Win 2000

When i load a database i get the following error in the error log

00:00000:00010:2004/03/10 10:39:07.41 kernel Connectivity Library (Directory Control Layer) Error: Error returned by service provider.

00:00000:00010:2004/03/10 10:39:07.41 kernel Connectivity Library (Directory Control Layer) Error: (InterfacesDriver): Requested server name not found.

00:00000:00010:2004/03/10 10:39:07.41 server Error: 7220, Severity: 11, State: 1

00:00000:00010:2004/03/10 10:39:07.41 server Site 'SYB_BACKUP' not found in interfaces file.

00:00000:00010:2004/03/10 10:39:07.41 server Error: 7235, Severity:

17, State: 0

00:00000:00010:2004/03/10 10:39:07.41 server No other query entry found for the remote server SYB_BACKUP - site SYB_BACKUP. Aborting this site handler, as no remote server responded. Please make sure the remote server is accepting connections.



I have tried restarting the backup server many times and it is starting but all that is not working

i require a very good mechanism to deal with this problem

its urgent
Reply With Quote
  #2 (permalink)  
Old
Registered User
 
Join Date: Jun 2003
Posts: 140
Talking Re: 'SYB_BACKUP' not found in interfaces file.

(1) Check -I parameter of the backupserver executable in the RUN file first

(2) If above parameter is not specified then look at the the SYBASE environment variable to locate the interfaces file. Update the Backup Server RUN file to reflect the location of the correct interfaces file.

(3) Check for srvname="SYB_BACKUP" in master..sysservers, it should be same as written in interface file. Also, the name in the interfaces file should be the same as that in the -s option of $SYBASE/install/RUN_backupserver file

verify for all above things and find out where the prob is

for more help checkout
http://info.sybase.com/resolution/de...umber=10875132
http://info.sybase.com/resolution/de...umber=10522412

hope this helps

Last edited by perl; 03-10-04 at 05:47.
Reply With Quote
  #3 (permalink)  
Old
Registered User
 
Join Date: Mar 2004
Location: Hyderabad, India
Posts: 8
Can I Use a hyphen in server names

ex MFD-REPLICA_BS

Right now, this is a test server and named as MFD-REPLICA
and Backup server as MFD-REPLICA_BS and MFD-REPLICA_MS

I have checked the sysservers table and it shows the server name as SYB_BACKUP and servernetname as SYB_BACKUP same as server name parameter.

Is giving the hyphen in the server name affecting my dump and load commands
Reply With Quote
  #4 (permalink)  
Old
Registered User
 
Join Date: Jun 2003
Posts: 140
I dont think hyphen is valid identifier , there is a function called
valid_name which verifies any given name is acceptable to ASE or not
if it returns 0 means its not valid , and with hyphen in any string it returns 0
Reply With Quote
  #5 (permalink)  
Old
Registered User
 
Join Date: Jul 2006
Posts: 3
I will try it and let you know what happen after that.
Reply With Quote
  #6 (permalink)  
Old
Registered User
 
Join Date: May 2005
Location: South Africa
Posts: 1,348
server Site 'SYB_BACKUP' not found in interfaces file

Quote:
Originally Posted by kapilsri
the sysservers table shows the server name as SYB_BACKUP and servernetname as SYB_BACKUP
servernetname should be the name as in your interfaces file e.g. REPLICA_BS
use sp_dropserver and sp_addserver to fix
Reply With Quote
  #7 (permalink)  
Old
Registered User
 
Join Date: Feb 2002
Location: Willy is on vacation
Posts: 1,208
Backup Server issues are always only at any one of these 3 places

1. RUN_<SERVER>_BS: Check the servername in the -s switch
2. Check the interfaces file has an entry for the same name as -s switch from Step 1
3. select srvname, srvnetname from sysservers wher srvname = 'SYB_BACKUP'
The srvname has to be SYB_BACKUP and the srvnetname should be the same as Step 1 and 2.

If all checks out
exec SYB_BACKUP...sp_ps
go
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On